NASZE SERWISY:    ANDROID   LINUX   MAEMO   SYMBIAN   WEBOS




Hosting sponsoruje:



GRIN3 - polskie fonty

Profesjonalne czcionki z polskimi znakami - czcionki.com

OpenMobile on Facebook


 

CodeWarrior i problem z konfiguracja SDK

CodeWarrior i problem z konfiguracja SDK

Postprzez _yapek_ » 14 grudnia 2007, o 23:47

Witam! Mógłby mi ktoś pomóc skonfigurować kompilator CodeWarrior do pisania aplikacji pod symbian 9.x? wersja kompilatora: http://www.forum.nokia.com/info/sw.noki ... n_3_1.html

sdk: http://www.forum.nokia.com/info/sw.noki ... .0-mr.html

Albo proszę o polecenie innego kompilatora symbian c++ dla wersji 9.x

Pozdrawiam!
_yapek_
1%
1%
 
Posty: 9
Dołączył(a): 18 lutego 2007, o 16:22
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez Pinio » 15 grudnia 2007, o 14:50

A co konkretnie jest nie tak? bo generalnie (już nie pamiętam, więc mogę się okrutnie pomylić) sdk się wybiera podczas tworzenia nowego projektu, tam jakiegoś szczególnego kombinowania nie pamiętam.

_yapek_ napisał(a):Albo proszę o polecenie innego kompilatora symbian c++ dla wersji 9.x
Polecam Carbide. Obecne wersje są już stabilne, a poza tym to właśnie Carbide jest/będzie rozwijany, natomiast CodeWarrior już nie będzie rozwijany.

BTW: Cabide i CodeWarrior to nie kompilatory, tylko IDE ;) Kompilatorem jest gcc (na przykład).
Pinio
30%
30%
 
Posty: 111
Dołączył(a): 21 grudnia 2005, o 02:21
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez _yapek_ » 15 grudnia 2007, o 15:58

Z tym "kompilator" "ide" to faktycznie... do tej pory programowałem w c, c++(winapi), javie. Są pewne różnice. Chciałem teraz napisać coś w symbian c++ ale nie mogę sobie poradzić ze środowiskiem.
_yapek_
1%
1%
 
Posty: 9
Dołączył(a): 18 lutego 2007, o 16:22
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez Pinio » 16 grudnia 2007, o 20:48

postaramy sie pomóc, ale musisz napisać co sie dzieje, jaki to problem :)
Pinio
30%
30%
 
Posty: 111
Dołączył(a): 21 grudnia 2005, o 02:21
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez _yapek_ » 16 grudnia 2007, o 22:21

Problem jest taki, że pokazuję mi się błąd z którym nie wiem co zrobić. (obrazek) SDK jest zainstalowane właściwie i katalog który wg systemu nie istnieje znajduje się pod podanym adresem.

Obrazek
_yapek_
1%
1%
 
Posty: 9
Dołączył(a): 18 lutego 2007, o 16:22
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez Pinio » 16 grudnia 2007, o 23:55

hmmm... wygląda jakby jednak coś nie tak z SDK było. Jesteś pewien że tam wszystko ok? Sprawdź może jeszcze czy masz zmienną systemową EPOCROOT dobrze wpisaną, może to to jest problem.
Pinio
30%
30%
 
Posty: 111
Dołączył(a): 21 grudnia 2005, o 02:21
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez b.polakko » 17 grudnia 2007, o 09:24

Moze projekt i sdk znajdują się na innych dyskach/partycjach?
Avatar użytkownika
b.polakko
1%
1%
 
Posty: 17
Dołączył(a): 17 października 2007, o 11:01
Lokalizacja: Karlsruhe
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez _yapek_ » 17 grudnia 2007, o 21:52

Rzeczywiście, sdk i projekt muszą być na tej samej partycji. :kwasny: Ale co z drugim błędem? Pojawia się przy kompilacji każdego najprostszego przykładu.

Obrazek
_yapek_
1%
1%
 
Posty: 9
Dołączył(a): 18 lutego 2007, o 16:22
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez Pinio » 17 grudnia 2007, o 22:46

No cóż, jak dla mnie są jeszcze dwie możliwości:
1. Sprawdź wersję ActivePerl - powinna być v5.6.1.635 - jeżeli masz inną, to wywal i zainstaluj tą
2. Zainstaluj wszystko na dysku C: - SDK, Carbide i ActivePerla (koniecznie w wersji powyżej, najlepiej po prostu w domyślnych lokacjach)

Jeżeli to nie pomoże - cóż, powiem za bohaterami serialu IT Crowd - "Have You tried to turn it off and on again?" ;)
Pinio
30%
30%
 
Posty: 111
Dołączył(a): 21 grudnia 2005, o 02:21
    WindowsXPFirefox

Re: CodeWarrior i problem z konfiguracja SDK

Postprzez _yapek_ » 19 grudnia 2007, o 13:14

Już działa. Wersja ActivePerl była niewłaściwa. :) Dzięki za pomoc. :padam: Teraz już chyba mogę przenieść się do działu "Symbian C++". Pozdrawiam! :luka:
_yapek_
1%
1%
 
Posty: 9
Dołączył(a): 18 lutego 2007, o 16:22
    WindowsXPFirefox


Powrót do Narzędzia i SDK

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

cron